it运维知识-捕鱼平台app

双子信息

information

it运维知识-华为dhcp中继配置

2018-01-12

关于“中继配置”可能很多人会不懂,但是只要是it运维人员一定知道是什么。中继代理是使在不同子网上的客户机都可以从配有dhcp功能的路由器上获取地址,所以就需要在中间的设备上配置dhcp中继。

本篇文章为大家分享为dhcp中继配置的it运维小知识!

实验拓扑图:

it运维

[sw1-vlanif10]dhcp select interface                       //基于接口分配ip

[r1-gigabitethernet0/0/0]dhcp select global              //基于全局地址池分配ip

[sw1-vlanif10]dhcp select relay                           //基于dhcp中继分配ip

一教室配置:

undo ter m

sys                           //进入系统视图

[huawei]sysname 1class                //更改设备名称

[1class]vlan batch 10 20                  //创建vlan10、20

[1class]int e0/0/1                    //进入接口

[1class-ethernet0/0/1]port link-type access   //配置接口类型为access

[1class-ethernet0/0/1]port default vlan 10    //配置接口属于vlan 10

[1class-ethernet0/0/1]int e0/0/2

[1class-ethernet0/0/2]port link-type access

[1class-ethernet0/0/2]port default vlan 20

[1class-ethernet0/0/2]int g0/0/1

[1class-gigabitethernet0/0/1]port link-type trunk        //配置接口类型为trunk

[1class-gigabitethernet0/0/1]port trunk allow-pass vlan 10 20 //运行vlan10、20的流量通过

[1class-gigabitethernet0/0/1]q

it运维

二教室配置

undo ter m

sys                               //进入系统视图

[huawei]sysname 2class                    //更改设备名称

[2class]vlan batch 10 20                      //创建vlan 10、20

[2class]int e0/0/1                        //进入接口

[2class-ethernet0/0/1]port link-type access   //配置接口类型为access

[2class-ethernet0/0/1]port default vlan 10    //配置接口属于vlan 10

[2class-ethernet0/0/1]int e0/0/2

[2class-ethernet0/0/2]port link-type access

[2class-ethernet0/0/2]port default vlan 20

[2class-ethernet0/0/2]int g0/0/1

[2class-gigabitethernet0/0/1]port link-type trunk    //配置接口类型为trunk

[2class-gigabitethernet0/0/1]port trunk allow-pass vlan 10 20 //配置仅允许vlan 10、20的流量通过

[2class-gigabitethernet0/0/1]q

汇聚层交换机配置:

undo ter m

sys                                   //进入系统视图

[huawei]sysname sw1                           //更改设备名称

[sw1]vlan batch 10 20 30                          //创建vlan 10、20、30

[sw1]int vlan 10                                  //进入vlan 10

[sw1-vlanif10]ip add 192.168.10.1 24              //配置vlan的ip地址

[sw1-vlanif10]int vlan 20

[sw1-vlanif20]ip add 192.168.20.1 24

[sw1-vlanif20]int vlan 30

[sw1-vlanif30]ip add 12.0.0.2 24

[sw1-vlanif30]q

[sw1]int g0/0/1                               //进入接口

[sw1-gigabitethernet0/0/1]port link-type trunk           //配置接口类型为trunk

[sw1-gigabitethernet0/0/1]port trunk allow-pass vlan 10 20       //配置仅允许vlan 10、20的流量通过

[sw1-gigabitethernet0/0/1]int g0/0/2

[sw1-gigabitethernet0/0/2]port link-type trunk

[sw1-gigabitethernet0/0/2]port trunk allow-pass vlan 10 20

[sw1-gigabitethernet0/0/2]int g0/0/3

[sw1-gigabitethernet0/0/3]port link-type access

[sw1-gigabitethernet0/0/3]port default vlan 30

[sw1-gigabitethernet0/0/3]q

[sw1]ip route-static 0.0.0.0 0.0.0.0 12.0.0.1     //添加一条到达路由器的默认路由

dhcp中继配置:

[sw1]dhcp enable                              //开启三层交换的dhcp功能

[sw1]int vlan 10                              //进入vlan

[sw1-vlanif10]dhcp select relay               //配置获取访问为relay

[sw1-vlanif10]dhcp relay server-ip 12.0.0.1   //配置dhcp服务器的地址

[sw1-vlanif10]int vlan 20

[sw1-vlanif20]dhcp select relay

[sw1-vlanif20]dhcp relay server-ip 12.0.0.1

[sw1-vlanif20]q

路由器dhcp服务配置:

undo ter m

sys                           //进入接口视图

[huawei]sysname r1                    //更改设备名称

[r1]dhcp enable                       //为路由器开启dhcp功能

[r1]ip pool v10                       //创建dhcp地址池

[r1-ip-pool-v10]network 192.168.10.0 mask 24      //配置地址池分配的网段

[r1-ip-pool-v10]gateway 192.168.10.1              //配置地址池的网关

[r1-ip-pool-v10]dns-list 10.10.10.10              //配置dhs服务器地址

[r1]ip pool v20

[r1-ip-pool-v20]network 192.168.20.0 mask 24

[r1-ip-pool-v20]gateway 192.168.20.1

[r1-ip-pool-v20]dns-list 20.20.20.20

[r1-ip-pool-v20]q

[r1]int g0/0/0                                //进入接口

[r1-gigabitethernet0/0/0]ip add 12.0.0.1 24       //配置ip地址

[r1-gigabitethernet0/0/0]dhcp select global       //配置基于全局地址池的方式分配ip

[r1-gigabitethernet0/0/0]q

[r1]ip route-static 0.0.0.0 0.0.0.0 12.0.0.2      //添加一条返回的默认路由

客户机设置:

pc1设置为dhcp自动分配地址

it运维

查看分配到的地址

it运维

pc2设置为dhcp自动分配ip地址

查看分配到的ip地址

pc3设置为dhcp自动分配ip地址

查看分配到的ip地址

pc4设置为dhcp自动分配ip地址

查看分配到的ip地址

ipconfig /release          //释放现有的ip地址

ipconfig /renew            //重新获取ip地址

最新新闻the latest news

分享到

china's leading it service brands

中国领先it服务品牌企业

销售热线:400-017-5181
故障处理:400-617-5181
同创双子(北京)信息技术股份有限公司(英文简称“gemini”)是一家it服务公司。2016年新三板正式挂牌上市(股票代码:837868)。 联系网上捕鱼

微信客服

it外包就扫我

电玩城捕鱼 copyright© 同创双子(北京)信息技术股份有限公司 , 京icp备16037308

网站地图

法律声明

未经本公司书面许可,任何单位及个人不得以任何方式或理由对上述产品、服务、信息、材料的任何部分进行使用、复制、修改、抄录、传播或与其它产品捆绑使用、销售。
凡侵犯本公司捕鱼平台app的版权等知识产权的,本公司必依法追究其法律责任。
本公司法律事务部受本公司指示,特此郑重法律声明!